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CodeWarrior Development Studio

for StarCore DSP Architectures
Quick Start for the Windows® Edition

SYSTEM REQUIREMENTS

Hardware Intel® Pentium® 4 processor, 2 GHz or faster,
Intel Xeon™, Intel Core™, AMD Athlon™ 64,
AMD Opteron™, or later
2 GB RAM
CD-ROM drive for CD installation
Microsoft Mouse compliant pointing device
Internet connectivity for web downloads and
update access

Operating System Microsoft® Windows 7 (32/64-bit)
Home Premium, Professional, Ultimate Operating
System
or
Microsoft® Windows Vista® (SP2) (32/64-bit)
Home Basic, Home Premium, Business,
Enterprise, Ultimate Operating System
or
Windows® XP Professional (SP3) (32/64-bit)

Disk Space 2 GB, additional space required during installation

This Quick Start explains how to install the CodeWarrior software on a
Windows PC. Also, the document explains how to use this software to
create, build, and debug a simple StarCore DSP project.

NOTE In the procedures that follow, advanced users can use
numbered steps. Novices may use the more detailed
instructions provided by substeps.



Section A: Installing Software

1. Install the CodeWarrior software
NOTE If you are installing from a CD, proceed directly to substep j.
Start a web browser.

b. Point the browser to https://www.freescale.com/cqi/go/189425101 — the
Freescale website's Log-in page appears.

c. On this page, enter your login information.

NOTE If you are not a registered user, click Register Now and follow
the on-screen instructions.

d. Click Log in — the Extranet Project: CodeWarrior StarCore v10.0 web
page appears.

e. On this page, open the folder containing the release to install — a list of
files appears.

f.  In this file list, click the name of the web installer. The web installer is a file
with .exe file extension — the File Download dialog box appears.

g. Click Save — the Save As dialog box appears.
h. Select a convenient location on your PC to save the installer.
i. Run the installer — the install wizard appears.

NOTE If you are installing from a CD, insert the Development Studio
for StarCore CD into the CD-ROM drive — auto install begins.

j.  Follow the wizard instructions to install the CodeWarrior software. When
the wizard is finished, the InstallShield Wizard Completed page
appears.

k. Check Check for program updates after the setup completes.
I.  Click Finish — the CodeWarrior Updater dialog box appears.

2. Check for software updates

NOTE If CodeWarrior Updater already has the required Internet
connection settings, proceed directly to substep h.


https://www.freescale.com/cgi/go/189425101
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NOTE

Click Settings — the CodeWarrior Updater Settings dialog box
appears.

Select Check Bi-Weekly from the Update Check Scheduling drop down
list.

Click Settings — the Internet Properties dialog box appears.

Use the dialog box to modify Internet settings, if necessary.

Click OK — the Internet Properties dialog box closes.

Click OK — the CodeWarrior Updater Setting dialog box closes.

In the CodeWarrior Updater dialog box, click Next — the updater checks
for the newer versions of CodeWarrior products.

Follow the updater’s on-screen instructions to download the CodeWarrior
product updates to your PC.

When the updater displays Update Check Complete! message, click
Finish — the wizard closes.

For licensing and activation of your CodeWarrior Development
Studio for Freescale StarCore DSP Architectures, refer to the
CodeWarrior Development Suite Quick Start. Save the license
file, license.dat to the installation root folder, the default is
CWInstallDir\SC,where CWInstallDiristhe pathto your
CodeWarrior installation.



Section B: Creating, Building, and Debugging a Project

1. Launch the CodeWarrior IDE

a. Select Start > Programs > Freescale CodeWarrior > CW for StarCore
< number> > CodeWarrior, where number is the version number of your
product — the Workspace Launcher dialog box appears.

Workspace Launcher Dialog Box

® workspace Launcher

Select a workspace

Freescale CodeWarrior stores your projects in a folder called a workspace.
Choose & workspace folder to use for this session.

Workspace: |D:'-Fruﬁles‘-:.-urkspaca1 v| | Browse... |

[Juse this as the default and do not ask again

b. If you wish to change the location of your project's Workspace, click
Browse to select a new path — the Select Workspace Directory dialog
box appears.

Select Workspace Directory Dialog Box

Select Workspace Directory

Select the workspace directory to use.

|5) Workspace2
|5 Workspace3
(53 Workspaces
|5 Workspace5
[C) Workspaceé
(2 Workspace7 =
[ warkspaces

< | >

[£4

Folder: | Workspacel |

l Make New Folder ] I oK H Cancel ]

c. Select the required folder or click Make New Folder to create a new
folder for storing your projects.

Click OK — the Select Workspace Directory dialog box closes.

e. Click OK to store the project at the specified location — CodeWarrior
launches and displays the Welcome page.



Welcome Page

CodeWarrior

Development Studio

() New Project Wizard What's New Product Release Notes
@4 Example Projects &7 Web Resourses Scrvice Packs, Updale
"_‘ Tutorials

& Project Importer
-

= Go to Workbench = ffreeiggg!g

NOTE The Welcome page is displayed when CodeWarrior is run for
the first time. You can always return to this page by selecting
Help > Welcome from the CodeWarrior IDE menu bar.

2. Create a new project

a. From the CodeWarrior IDE menu bar, select File > New > Project — the
New Project dialog box appears.

b. Select StarCore Project.



New Project Dialog Box

2 New Project

Select a wizard
Create a new StarCore project |

Wizards:

[type filter text

ﬁ StarCore Project
(= General
[ CodeWarrior
= cvs

[ show all Wizards.

S

c. Click Next — the Create a StarCore Project page appears.

NOTE You can also open the Create a StarCore Project page
directly by selecting File > New > StarCore Project.

d. Inthe Project name field, type Demo.

New StarCore Project Wizard

® New StarCore Project

Create a StarCore Project - Step 1 of 6
Choose the location for the new project

New Project Name: ‘ Demo

Use default location

< Back Next > | [ FEinish ] [ Cancel




e. Click Next — the Devices page appears.

f. Select the SC3x00 option in the Device Family Group.

g. Select the Application option from Project Type.
Devices Page

2 New StarCore Project

Devices - Step 2 of 6
Choose the target device for this project.

Device Family Group:

0
SC3x50
M5Ca144
MSC&15x Family
MSC825x Family

Project Type:
(=) application
() Component Library
() Self-Contained Library
() simple Library

Select this option to generate projects for the following single-core targets: SC3x00 Platform
IS5, SC3%00 Platform PACC,

h. Click Next — the Build Settings page appears.

NOTE The Build Settings and Simulators pages appear according
to target device selected from Devices page.




Build Settings Page

2 New StarCore Project

Build Settings - Step 3 of 6
Memory model: |Huge -
Languages:
®c
Oc++
() Assembly
@ [ < Back ” Next > I [ Finish ] [ Cancel ]

i. Click Next — the Launch Configurations page appears.

j-  Check the Disable memory verification after program download
checkbox if you do not want to verify the program download.

NOTE For certain programs, verification of programs might prevent
connection to TAP. If you can connect to a TAP, this option
does not affect trace collection.

k. Inthe Launch Configuration Options, select the Create launch
configurations for both debug and release targets option to generate
both debug and release launch configurations.



Launch Configurations Page

Launch Configurations - Step 4 of 6

Debugger Connection Type:

Simulator

Program Download Option:
Disable memoary verification after program download

Launch Configuration Options:
() Create template launch configurations for debug targets only
() Create all launch configurations for debug targets
(%) Create launch configurations for both debug and release targets

@ [ <Back || MNext> ‘[ Finish ][ Cancel

I.  Click Next — the Simulators page appears.
Simulators Page

Simulators - Step 5 of 6
Choose the simulator to run this project on.

Simulator:

[] Local 5C3x00 Platform PACC

=)

< Back ][ Mext > ]I Finish H Cancel




m. If target device is SC3x00, check Local SC3x00 Platform ISS or Local
SC3x00 Platform PACC checkbox to use Instruction Set simulator or
Platform Accurate simulator respectively.

NOTE For other target devices check appropriate checkbox from the
available simulators.

n. Click Next — the Software Analysis Trace and Profile page appears.

Software Analysis Trace and Profile Page

 New StarCore Project

Software Analysis Trace and Profile - Step 6 of 6
Enable trace and profiling for this project.

[C]Enable trace and profile

Check Enable trace and profile option if you want to collect results without any
other changes in the project.

@ < Back [ Fnmsh ][ concel |

o. Check the Enable trace and profile checkbox to collect trace and
profiling data.

NOTE If you selected the Local SC3x00 Platform ISS checkbox on
the Simulators page, the Enable trace and profile checkbox
appears disabled.

p. Click Finish — the IDE creates the project. You can view the newly
created project in the CodeWarrior Projects view in the IDE.
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CodeWarrior Projects View

=0
= dgbp File Mame =

Size  Type Build

Q? analysis_simulator_setup.da’ 1KB v
(= Application_File
[l Includes
(=~ Debug_Settings
[ LCF

readme_SC3x00_Platform_P 1KB Text v
(= Source

(= Trace_Profile_Results

3. Build and debug program

a. Select the project in the CodeWarrior Projects view.

b. Select Project > Build Project to build the project. Alternatively, you can
right-click on the project in the CodeWarrior Projects view and select
Build Project from the context menu.

c. From the CodeWarrior IDE menu bar, select Run > Debug
Configurations — the Debug Configurations dialog box appears.

d. Select CodeWarrior Download > demo - Debug_SC3x00_PACC -
SC3x00 Platform PACC in the left pane.

Debug Configurations Dialog Box

ebug Configurations

Create, manage, and run configurations
Dowrload an application to a target, then debug or run the application.
+ = ED
) i -
MERANSE: MName: | demo - Debug_5C3x00_PACC - 5C3x00 Platform PACC |
type fiter text = =
Main (9= Arguments | Fi§ Environment | %5: Debugger | & Source | =] Common | g’ Trace and Profle
l ) b = d Profi
[E] Codewarrior Attach
= Project:
| demo | [ orowse... |
— CHASSE | | o tion:
demo - Release_SC3x00_PACC - (B
B Launch Group [ Debug_sc3x00_PACC/demo.eld | [search Project... | [_Browse... ]
& | £
Fiter matched 6 of 6 items

e. Click Debug — program downloads to simulator.
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f. Click Yes — the Debug perspective appears and the execution halts at
the first statement of main ().

Debug Perspective

2 Debug - demo/Source/starcore_main.c - Freescale CodeWarrior
Fle Edt Refactor Navigate Search Project Profier Run Window Heb

L3~ EE-O-B-F S F-H-B P 0-Q &9 | %5 Debug | By cre++
%5 Debug 2 = 5[t variables 57 . © Breakpoints | [ Cache | M1} Regsters | = Mockies =8
= P =

Dm0 @ BN i m - || Name Value Location

=[] demo - Debug_SC3x00_PACC - SC3x00 Pitform PACC [CodeWarrior Download]
= starCore DSP, demo.<id, core 0 (Suspended)
=1 P Thread [ID: 0] (Suspended: Signal Halt received. Desariptions User haited th
Bl 2 mein( D: norkspace 1\demo Sourcestarcore main.c:55 040000000
= 1 (asmSection) ) d:\ build\v23_10_2_4_3x50\ library\srcltib\expandeds | < 2

4] DrWworkspace 1\demo\Debug_SC3x00_PACC \demo.eid (10/12/09 12:06 PM)

< >

Marker =5

8] starcore_main.c &2 = O | [ visassembly 53 B outine
Bar A ane mesno A
return (0) ; » 0x40000000 <main>: addi
) g

return funcl ()

T int main() 0x40000002 <main+2>: Jsr
f 0x40000008 <main+g>: mowe
retarn funcl(): 0x40000002 <main+10>: move
) 0%4000000¢ <maintl2>: sub
0x4000000e <main+1ss: rts
< >
) Console 8 ¥ Tasks| 0 Memory | {al Target Tasks | (11 Problems | ) Executables ] % pilE[@ et B-r5- 70
StarCore DSP, demo.eld, core 0
- demo - Debug_SC L=

g. Click on the thread in the Debug view — the program counter icon %
on the marker bar points to the next statement to be executed.

h. In the Debug view, click Step Over ‘2 — the debugger executes the
current statement and halts at next statement.

4. Set breakpoint and execute program to breakpoint.

a. Inthe editor area, scroll to this statement:
for (1 = 0; 1 < DataBlockSize/2; i++ )

b. Double-click on the marker bar next to the statement — the breakpoint
indicator (blue dot) appears next to the statement.

c. Inthe Debug view, click Resume [ — the debugger executes all
statements up to but not including the breakpoint statement.

5. Control program

a. Inthe Debug view, click Step Over ‘Z: — the debugger executes the
breakpoint statement and halts at the next statement.

b. Inthe Debug view, click Resume [I# — the program outputs to the
Console window at the bottom.

c. Inthe Debug view, click Terminate [l — the debug session ends.
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6. Close the Console window

7. Select File > Exit — the CodeWarrior IDE window closes.

Congratulations!

You have created, built, and debugged a StarCore DSP
Simulator project using CodeWarrior!
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Freescale, the Freescale logo, CodeWarrior and StarCore are trademarks of Freescale
Semiconductor, Inc., Reg. U.S. Pat. & Tm. Off. All other product or service names are the
property of their respective owners.

© 2009-2010 Freescale Semiconductor, Inc. All rights reserved.

Information in this document is provided solely to enable system and software implementers to
use Freescale Semiconductor products. There are no express or implied copyright licenses
granted hereunder to design or fabricate any integrated circuits or integrated circuits based on
the information in this document.

Freescale Semiconductor reserves the right to make changes without further notice to any
products herein. Freescale Semiconductor makes no warranty, representation or guarantee
regarding the suitability of its products for any particular purpose, nor does Freescale
Semiconductor assume any liability arising out of the application or use of any product or
circuit, and specifically disclaims any and all liability, including without limitation consequential
or incidental damages. “Typical” parameters that may be provided in Freescale Semiconductor
data sheets and/or specifications can and do vary in different applications and actual
performance may vary over time. All operating parameters, including “Typicals”, must be
validated for each customer application by customer's technical experts. Freescale
Semiconductor does not convey any license under its patent rights nor the rights of others.
Freescale Semiconductor products are not designed, intended, or authorized for use as
components in systems intended for surgical implant into the body, or other applications
intended to support or sustain life, or for any other application in which the failure of the
Freescale Semiconductor product could create a situation where personal injury or death may
occur. Should Buyer purchase or use Freescale Semiconductor products for any such
unintended or unauthorized application, Buyer shall indemnify and hold Freescale
Semiconductor and its officers, employees, subsidiaries, affiliates, and distributors harmless
against all claims, costs, damages, and expenses, and reasonable attorney fees arising out of,
directly or indirectly, any claim of personal injury or death associated with such unintended or
unauthorized use, even if such claim alleges that Freescale Semiconductor was negligent
regarding the design or manufacture of the part.

How to Contact Us

Corporate Freescale Semiconductor, Inc.
Headquarters 6501 William Cannon Drive West

Austin, Texas 78735

U.S.A.
World Wide Web http://www. freescale.com/codewarrior
Technical Support http://www. freescale.com/support
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