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The QCVS components also allow you to perform offline validation of the configured data; therefore, helping you create a valid
configuration. Your configuration is validated against constraints documented in the reference manual and errata for the processor.

This document explains how to create a new QorlQ configuration project and generate a component output. It also describes how
you can view the component properties and introduces the validation support offered by QCVS.

2 Creating a new QorlQ configuration project

This section explains how to create a new QorlQ configuration project.
To create a new QorlQ configuration project, perform these steps:
1. Run the Eclipse environment.
2. Choose File > New > QorlQ Configuration Project from the IDE menu bar.
The New QorlQ Configuration Project wizard starts, displaying the Create a QorlQ Configuration Project page.

3. Enter a name for the project in the Project name field, as shown in the figure below.
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Creating a new QorlQ configuration project

.

¥ New QorlQ Configuration Project

Create a QorlQ Configuration Project

Choose the location for the new project

Project name:  QorlQ_Project

| Use default location

C:/Users/b34823 /workspace?l/QorlQ_Project

. < Bac

Cancel

Figure 1. Create a QorlQ Configuration Project page

4. If you want to create the project in a folder different from the default folder, then deselect the Use default location checkbox

and specify a new folder location in the Location field.

5. Click Next. The Devices page appears.

6. Choose the target processor for the project from the Processor to be used list. You can use the Processor to be used

field to filter the processors list.

7. Choose the processor silicon version from the Choose a silicon version field, in case multiple versions of the silicon are

supported.
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Creating a new QorlQ configuration project
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Figure 2. Devices page
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Creating a new QorlQ configuration project

8. Click Next. The Toolset selection page appears.

9. Choose the QCVS component(s) you want to configure, from the Components to be selected list, as shown in the figure
below.

P

¥ Mew QorlQ Configuration Project = @
Toolset selection

Choose what do you want to configure

Components to be selected

type filter text

a [ | Components
DDR Memary Controller Configuration
[] PBL - Preboot Loader RCW configuration
[] Pin Muxing Configuration
[] SERDES Configuration Tool

The DDR Memary Controller configuration tool supports the specific settings for a custorn DDR
based on the manufacturers data sheet and includes optional clock, bus and DMA settings.

|ﬁ:‘| < Back “ Mext = I [ Finish ] I Cancel

Figure 3. Toolset selection page

NOTE
The Toolset selection page only displays components that you can configure for the processor you selected on
the Devices page.

10. Click Next.

A configuration page appears based on the component(s) you selected on the Toolset selection page. The figure below
shows the configuration page for the DDR component. If you selected multiple components on the Toolset selection
page, then you may get multiple configuration pages.
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Creating a new QorlQ configuration project
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Figure 4. DDR configuration page
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Creating a new QorlQ configuration project

11.  Click Finish.

The project is created and displays in the different views of the QCVS perspective. A perspective defines the initial settings
and layout of views in the Workbench window. As shown in the figure below, the QCVS icon toward the top-right corner
of the Workbench window indicates that the QCVS perspective is enabled currently.
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. . . 4 SerDes 2 Reference Clocks
4 [ Generator_Configurations
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Figure 5. QCVS perspective

The main views in the Processor Expert perspective are:
¢ Project Explorer
* Connections View
e Components View
¢ Component Inspector
e Components Library
* Problems View

To know more about the QCVS perspective and its views, see QCVS Processor Expert User Guide.
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QCVS components

3 QCVS components

This section describes how to configure QCVS components.

The table below lists the QCVS components and the documents you can refer to for more information on them.

Table 1. QCVS components

QCVS component Described in

PBL QCVS PBL Tool User Guide

DDR QCVS DDR Tool User Guide
SerDes QCVS SerDes Tool User Guide
PinMuxing QCVS PinMuxing Tool User Guide

The Component Inspector view allows you view and configure properties of a QCVS component. Right-click a QCVS component
under the Components folder of the Components view and choose Inspector from the shortcut menu. The properties of the
component are displayed in the Component Inspector view, as shown in the figure below. You can configure the component by
changing its properties in the Component Inspector view.
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¥ QCvs - CodeWarrior Development Studio for QorlQ LS series - ARM V8 ISA (== |[==]
File Edit Mavigate Search Project Run Processor Expert Window Help
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Properties “._Import| Export| Validation
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E o Device DDR_Contraller_1 DDR_Controller_1
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SDRAM self refresh during Enabled
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4 (= Processors
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Figure 6. Component Inspector
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Generating component code

For more information on how to configure or work with an embedded component of QCVS, see the corresponding document listed

in the table above.

4 Generating component code

After defining a configuration, you can generate the code (output) for the QCVS component.

The generated code for a QCVS component can be one of the following:

* Register values that map to the configured module in case of embedded hardware devices

* Source code in different programming languages or calls to different software application programming interfaces (APIs)

that you can copy within your software system

¢ Other configuration data files, such as pre-boot loader (PBL) image file

Perform one of the following steps to generate component code:

¢ Click the Generate Processor Expert Code icon in the Components view (see figure below)

* Right-click ProcessorExpert.pe in Project Explorer and choose Generate Processor Expert Code (see figure below)

* Choose Project > Generate Processor Expert Code from the Eclipse IDE menu bar

Generate Processor Expert Code icon

3;' QCVS - CodeWarrior Development Studio EI@
File Edit Mavigate Search Project Run| Processor Expert Window Help
- | % @~ - - - - Ej@c_,'c++
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=
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B 1510214 v2 0_Cnf New 5
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=
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odule
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. gmpmem - S 800 MHz DDR Data Rate: 1600 MT/s
=4
) DDR_mcl:DDR Copy Ctrl+C Unbuffered DIMMs
- Past Chrla 32-bit bus
aste Ctrl+V
m
Delete Delete E
L[5 Project Explorer % X |
Move... ring sleep Enabled
-q |
4 &= Qorld Project . Rename F2  pd Correction) Disabled
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Disassemble :: et DO el
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Show in Remote Syst . Eshes 1 refresh is issued at a time
ow in Remote Systems view i
& The DDR contreller will be run at DDR-1250 or higher
Clean Selected File(s) W no
Build Selected File(s) p Configuration  On-the-fly Burst Chop mode is disabled
) Generate Processor Expert Code Disabled
e I} Disabled
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Debug As no
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Team
Compare With pins DRAM pins
Replace With = il
#7 Run C/C++ Code Analysis [ 1 3
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% QorIQ_Projec
Properties Alt+Enter
Show In Windows Explorer
Figure 7. Generate Processor Expert code
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Target connection

The code generation starts and the progress is indicated in the Generating code dialog, as shown in the figure below.

¥ Generating code = @

'6' Generating code - DOR_mcl component

-

-

Always run in background:

Run in Ear_kgmund] | Cancel | | Details ==

Figure 8. Code generation

The Generating code dialog closes after completion of code generation and the generated code files are added under the
Generated_Code folder of Project Explorer, as shown in the figure below.

=]
%v

L[ Project Explorer &3 -
a =3 Qorl Project
- == Documentaticn
4 [ Generated_Code
- L] InithrT:‘\egisters_l.c
-+ L£] uboot_ddrl.c Generated files
@ ddrCtrl_1.tcl
= Sources
% Processorbxpert.pe

Figure 9. Generated code files

5 Target connection

Each validation tool uses a client—server architecture to allow validation on both local and remote systems. If you have a target
board connected to your computer using a probe, then you can validate it locally. By default, validation is performed on the local

system.
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Target connection
With a new QCVS project, a default target connection is created using a CodeWarrior TAP probe with an empty connection string.
You can set up (create new, edit, or delete) a target connection using the Connections View.
To open the Connections View, follow these steps:
1. Choose Window > Show View > Other. The Show View dialog appears.
2. Choose Processor Expert > Connections and click OK. The Connections View appears, as shown in the figure

below.
BEE Connections View 53 = 8
Target connections
@6 & 0]
Processor Probe Type Probe Address  ITag speed (kHz)
LS2088A cwtap 10.171.77.9 10220

Figure 10. Setting up target connection

As shown in the figure above, the Connections View displays a connections table, with details of all the available connections.
The active connection is displayed in bold in the connections table. The Connections View also displays New, Edit, and Delete
buttons for creating a new connection and editing or deleting the connection selected in the connections table.

A button to verify the status of the active target connection, along with a status indicator for the active target connection, is displayed
at the top-right corner of the Connections View. You can click the button to verify whether or not the active target connection is
working properly. The connection status indicator shows:

* A chain with a red mark to indicate a failed connection
¢ A chain with no red mark to indicate a working connection

Each time you select a different connection in the connections table, the connection status gets verified and it is indicated by the
connection status indicator. The button shows either a green or red icon on it. The green icon indicates that you can click the
button to verify the active target connection status. The red icon indicates that the connection status is getting verified and you
can click the button to abort the verification process.

To create a new connection, follow these steps:

1. Click the New button in the Connections View. The New connection dialog appears (see figure below) that allows to
specify details for the new connection.
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Validation support

Mew connection... &3
Mame: Mew target
Processon L520884A -
Probe type: CWTAP -

Probe address:

nsa

b Advanced

Cancel | | Save

Figure 11. Creating a new connection

Specify a name for the new connection in the Name field.
Choose target device (processor) you want to connect to from the Processor menu.
Choose probe type (for example, CodeWarrior TAP) from the Probe type menu.

Specify probe address (for example, ID or IP address) in the Probe address field.

o o~ 0D

Click Save to save the connection settings and close the New connection dialog.

6 Validation support

QCVS provides validation features on the top of the configuration capabilities.

Besides the configuration capabilities, QCVS provides validation support, which can be accessed with a valid license. Currently,
validation support is provided for the DDR, PBL, and SerDes components. For more information, see QCVS DDR Tool User
Guide, QCVS PBL Tool User Guide, and QCVS SerDes Tool User Guide.
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