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Development Suite

Eclipse Quick Reference Windows ® Hosted

Menus and Keyboard Shortcuts (some menus/items can be hidden in any perspective)

File Menu Source Menu

New Alt+Shift+N > Toggle Comment Ctrl+/

Open Path Ctrl+Shift+A Add Block Comment Ctrl+Shift+/
Open File Remove Block Comment Ctrl+Shift+\
Close Ctrl+W Shift Right

Close All Ctrl+Shift+W Shift Left Shift+Tab
Save Ctrl+S Correct Indentation Ctrl+l

Save As Format Ctrl+Shift+F
Save All Ctrl+Shift+S Add Include Ctrl+Shift+N
Revert Sort Lines Ctrl+Alt+S
Move Implement Method

Rename F2 Generate Getters and Setters

Refresh F5 Surround With Alt+Shift+Z | 3
Convert Line Delimiters To > Refactor Menu

AL (i Rename Alt+Shift+R
Switch Workspace > Extract Local Variable Alt+Shift+L
sl Extract Constant Alt+C
Import Toggle Function Alt+ShiftsT
S Extract Function Alt+Shift+M
Prgpertles Alt+Enter Hide Method

A Apply Script

Edit Menu Create Script

Undo Ctrl+Z History

Redo Ctrl+Y

Cut Ctrl+X

Copy Ctrl+C » Denotes a hierarchical menu

Paste Ctrl+V

Delete Delete Note: Most of these menu items are dynamic and will
Select All Ctrl+A change relative to the active context.
Expand Selection To >

Find/Replace Ctrl+F

Find Word

Find Next Ctrl+K

Find Previous Ctrl+Shift+K

Incremental Find Next Ctrl+J

Incremental Find Previous ~ Ctrl+Shift+J
Add Bookmark

Add Task

Smart Insert Mode Ctrl+Shift+Insert
Show Tooltip Description F2

Word Completion Alt+/

Quick Fix Ctri+1

Content Assist Ctrl+Space
Parameter Hints Ctrl+Shift+Space

Set Encoding

h o
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Menus and Keyboard Shortcuts (continued)

Navigate Menu

Go Into

Go To

Open Declaration
Open Type Hierarchy
Open Call Hierarchy
Open Include Browser
Toggle Source/Header
Open Element

Open Type in Hierarchy
Open Element in Call
Hierarchy

Open Resource
Show In

Quick Outline

Next Annotation
Previous Annotation
Last Edit Location
Go to Line

Back

Forward

Search Menu
Search

File

C/C++

Text

Project Menu

Open Project

Close Project

Build All

Build Configurations
Build Project

Build Working Set
Clean

Build Automatically
Make Target
Generate Makefiles
Properties

F3

F4
Ctrl+Alt+H
Ctrl+Alt+
Ctrl+
Ctrl+Shift+T
Ctrl+Shift+H

Ctrl+Shift+R
Alt+Shift+W
Ctrl+O
Ctrl+.

Ctrl+,
Ctrl+Q
Ctrl+L
Alt+Left
Alt+Right

Ctrl+H

Ctrl+B

Ctrl+6

vy

Run Menu

Move to Line (C/C++)

Resume At Line (C/C++)

Resume

Suspend

Terminate

Resume Without Signal

Step Into

Step Over

Step Return

Run to Line

Run Ctrl+F11
Debug F11
Profile

Profile History

Profile As

Profile Configurations
Run History

Run As

Run History

Run As

Run Configurations
Debug History

Debug As

Debug Configurations
Toggle Breakpoint

Toggle Line Breakpoint
Toggle Method Breakpoint
Toggle Watchpoint

Skip All Breakpoints
Remove All Breakpoints
Breakpoint Types >
Reset

Multicore Resume
Multicore Suspend
Multicore Restart
Multicore Terminate
External Tools >

YyVYyVYY Yy

vy

Ctrl+Shift+B

Alt+Shift+F8

» Denotes a hierarchical menu

Note: Most of these menu items are dynamic and will
change relative to active context.



A 4
4\

Menus and Keyboard Shortcuts (continued)

Window Menu

New Window

New Editor

Open Perspective >
Show View >

Customize Perspective

Save Perspective As

Reset Perspective

Close Perspective

Close All Perspectives

Navigation >
Refresh Debug Views

Preferences

Help Menu

Welcome

Help Contents

Search

Dynamic Help

Key Assist Ctrl+Shift+L
Videos

Tip and Tricks

Cheat Sheets

Check for Updates

Install New Software

Documentation

StarCore Device Information

About CodeWarrior Development Studio
Freescale Licenses

» Denotes a hierarchical menu

Note: Most of these menu items are dynamic and will
change relative to active context.
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Welcome Page

* Debug - CodeWarrior Development Studio
Fls Dt Sourcs Refsctor Navigse Sewch Fromct fun Window Heb

DY

®

CodeWarrior Development Studio

©

(£) New Project Wizard

What's New Product Release Notes

©

@4 Example Projects

@)

&7 Web Resources Service Pac

()

ks, Updates,

@ . Go to Workbench [4] Tutorials @
=~ freescale
CodeWarrior
=
1.  Welcome page — the first page you see 7. Takes you to the web resources for
when you launch Eclipse IDE for the first CodeWarrior Development Tools and
time StarCore Device Documentation
2. Launches the New Project wizard 8. Takes you to the Tutorials page that pro-
3. Provid h | ) vides links to the Cheat Sheets, Getting
. roy| es you access to the sample projects Started guide and Help system
available in the product
4. Takes you to the Workbench window Tips and Tricks
5. Welcome page toolbar. Toolbar options * To return to the Welcome page or to
include (from left to right): access the Welcome page from the
Home Workbench window, select Help >
Navigate to previous topic Welcome from the IDE menu bar.
gavigate to next topic * To customize the Welcome page, click the
Medutf:fe Customize page icon in the Welcome
Cagnl y_ page toolbar. In the Customize dialog box,
M‘,‘S,t"f‘"'ze page click the appropriate tab and make the
inimize required changes.
Restore
6. Gives you information about the major new * Depending on the product you are work-

features in this release of the product

ing with, there may be a slight variation in
the screenshot of the Welcome page
above and/or the screenshots on page 4-
11 of this card.



\
Y

4
A

Workbench Window — C/C++ Perspective
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] int funcz ()
I
- - i Wpragma moinline
o Contmnander 1 w7 =0
&l 61 Printf("Hello private textin®):
= Project Creation - Msce [ return 03
iz et peaject & wee Bl
B Codewarrior Barsbosrdfroject 4 Flat
e void vestor_dvb_produet_16x16 (Vordiz tpx, fordsz a
&, Bad (AL bt * £
¥ Coan () [.: Prebloss £ Tasks | [ Consele | 1 Propertios | 8 Remete Systencs l
i tebg
e
= settings Desergeon P wexn | Tyem
i Project settngs ® 0 o (1 e

 CIC++ - BABEDISSSources/BED_main.c - CodeWarrior Development Studio

ect. Bum werkm e

=il —0

Ao cottes
Iy

W=

No ok

8.
9.

(" Wrkabls Srnrt Inebart ! L4 E Lo ‘I 5
Workbench window 14. Click to maximize the View stack (in this
Workbench menu bar case, for the Problems view)

Workbench toolbar containing com- 15. Welcome page icons
mands for C/C++ perspective Tips and Tricks

CodeWarrior Projects view
CodeWarrior Projects view toolbar
Problems view
Perspective switcher. Toolbar options
include (from left to right):

* Open perspective

¢ C/C++ perspective
Editor area
Outline view

10. Tabbed views or View stack (Problems,

Tasks, Console, Properties, and Remote
Systems views)

11. Toggle visibility of details pane
12. Problems view pull-down menu. Menu

options include:

e Show

* Group By

¢ Sort By

* New Problems View
* Configure Contents
¢ Configure Columns

13. Click to minimize the View stack (in this

case, for the Problems view)

To activate a view that is part of a tabbed view or
view stack, click its tab.
Press Ctrl+F6 to switch between editors,
Ctrl+F7 to switch between views, Ctrl+F8 to
switch between perspectives, and F12 to acti-
vate the editor.
To see a complete list of the currently available
key bindings in the editor or view you are cur-
rently working with, press Ctrl+Shift+L.
To quickly import files and folders to your work-
space, drag them from the Windows file sys-
tem to a view, such as CodeWarrior Projects
view. Similarly, to export files and folders, drag
them from a view to the Windows file system.
To change the default way perspective opens
in the Workbench window, such as to openiitin
a different window, use the Open a new per-
spective options in the Window > Preferences
> General > Perspectives page.
Right-click the title of a view to:
* Display it as a fast or detached view
* Restore or move the view
* Size the view to left, right, top or bottom
* Minimize, maximize, or close the view
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Workbench Window — Debug Perspective

™ Dabug - B4860IS5/Sources/b4860_main.c - CodaWarrior Davalopment Studic
Fie Edt Sousce fefactor Needgate Search  Project Run Window  Help
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@— i vty 03 = |0 varisties | P Dreskpoiots | [ cache | i Regsters 11
= 5 Fe w4
(:)__ 2w . Al | M E T | N Location
.= 5 Wi serrsl Purmose Regiters
Ll ded Sivdstor Hegisters
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Vordi2 prod_ref = OxDAELL3EC:

0z Wordi: prod:

< >

B Concle

4 Commander.

000 Sed:
101

adda. lin K#50. 50,10
int nunber_of_error_valuessl,

Y _STEC 4

&) Tasks| () Memary | g8 femete Sys | T Target Task [2) Problems | () Exeautabins
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= Project Creation Sy EiG I T T L T EE R -
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1. Workbench toolbar containing commands  Tips and Tricks
for Debug perspective
) 1. To open other views in a perspective, select
2. Debug view Window > Show View > Other and select a
3. Debug view toolbar new view from the Show View dialog box.
4. Editor area ¢ To save the changes made in the cur-
5. Commander view rent perspectlv.e, select Window >
Save Perspective As.
6. Show View as a fast view button. Clicking ] ) o
the button displays a list of views. Select e To return‘the perspective to its or.lglnal state,
a view from the list to display it as a fast select Window > Reset Perspective.
view )
* To open a new perspective, select
7. View stack (Variables, Breakpoints, Window > Open Perspective > Other
Cache, Registers, Modules) and select a new perspective from
) ) the Open Perspective dialog box.
8. Variables view
9. Console view
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Editor Area
ébi{tl E.ILLJU, 176, é“ v g 0, ;:‘U’ éi{‘lhu, g: ' é'ln’-il.'.-', étlllh. é:{lll.: @
Int func? ()
©@ | | A——
: :::::i:: 1 vate cexctin®):
G| [oia vector_det_product 1Gxlé [Wordli Tpx, WordlZ Tpy, int léngth, Wordli Tres)
e
1 y £2, sum_i2, sws_rdi
1. Quick diff, which displays color-coded Tips and Tricks
indication for additions, deletions, or
changes made to the contents of a file » Toopen allist of all open editors and quickly
switch between editors, press Ctrl+E.
2. Marker Bar ¢ You can open a file in the editor
. area by dragging the item from a
3. Auto Breakpoint view, s{lch agscgdeWarrior
4. Hardware Breakpoint Projects or Project Explorer and
dropping it over the editor area.
5. Software Breakpoint ¢ To activate single-click opening for
editors, use the Open mode options in
6. Disabled Breakpoint the Window > Preferences > General
page. In single-click mode, a single-click
7. Bookmark Marker on a file selects and immediately opens
the file.
8. Task Marker ¢ Double-clicking in the marker bar
(2) sets or removes breakpoints.
9. An asterisk (*) appearing at the left side ¢ To move lines up and down in the
of the tab indicates that the editor has editor, press Alt+Arrow Up and
unsaved changes Alt+Arrow Down.
* To view two or more sections of a source
10. Icons that flag error, warning, task and

bookmark markers. You can view extra
information by placing the mouse cursor
over the marker

file at the same time, open a similar editor
using Window > New Editor. Drag the new
editor tab and drop it over the left, right,
top, or bottom border of the editor area.
To activate code completion, press
Ctrl+Space.

To activate quick diff, right-click the
markerbar (2) and select Show Quick

Diff from the context menu.

When the mouse cursor is placed over a
change in Quick Diff (1), a hover displays
the original content, which can be
restored using the marker bar context
menu.
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Debug Configurations Dialog Box

* Debug Configurations

Create, marage, and run conligurations
Db o s appkcation b2 4 bargat

T
(] p4senssDeme Detug paec | 7 T
(] pasecnssDena Debug P4t Froet [y
B Lanch Geoun
- P —
* B [ required) befoee Launching

ancting

B cordipration:

) Bratie stz badd
) Use weorkspace settrgs

% »

o 9 f 1
@——

[

5

[T —]

Conpustion . AL Dotusg B0 Demricod ¥ [__ESE

[
3
[ prowse.
Search Poiect... | [ Bvcwmse... | [ Variabies
J [
S ) (o] @

1. Toolbar options include (from left to right):
* New launch configurations

* Duplicates the currently selected launch
configuration

¢ Delete selected launch configuration(s)

¢ Collapses all expanded launch
configurations

» Filter launch configurations
2. Type text to filter the launch configurations

3. List of launch configurations that apply to the
current application. CodeWarrior generates
launch configurations with names that follow
the pattern projectname-configtype-target-
type

4. Type text to filter the projects

5. Specifies the name of launch configuration
selected in the list (3)

6. Shows following tabs:

¢ Main: Identifies the project and
application you want to debug

* Arguments: Specifies the program
arguments and working directory that an
application uses for a debug
configuration

* Debugger: Specifies the debugger to use
when debugging an application

* Trace and Profile: Specifies the trace and
profiling options required for hardware
profiling

* Source: Specifies the location of source
files used when debugging an
application

* Environment: Specifies environment
variables and values to use when an
application runs

* Common: Specifies the location in which
to store the run configuration and how to
access it, how standard input and output
is handled, and if background launches
are enabled or not

7.  Click to debug the selected launch
configuration
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Preferences Dialog Box

= Preferences

Appearance
Capabilties
ComparefPatch
Content Types
Diagnostic Information
Drag and Drap
Editars
High Latency File System
Keys
Netvark Connections
Perspectives
Search
@ Security
Startup and Shutdown
Web Browser

Workspace
CfC++
Coloring Editar

Freescale Licenses
Help
Install{Update
Processor Expert

Remote Launch
Remote Systems
RunfDebug

Software Analysis
Team

Terminal
1 Trace Canfigurations

@

®

®

General | hd

[ Always run in background
[keep next/previous editor, view and perspectives dialog open
[[]show heap status

Open mode

(=) Double click

(Csingle dlick

Note: This preference may not take effect on all views

Restore Defauls Apply

1. Type text to filter the preference panels

2. Select a preference panel from the hierarchi-
cal list to view and edit its settings on the
right. The collection of panels varies,
depending on the current build target and

chosen settings

3.  Allows you to navigate through the previously

viewed pages

4. Edit preference settings in this panel

5. Restore default settings

6. Save settings for the current project
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Help View

++ - Project1/readme_b4B60ISS.txt - CodeWarrior Development Studio

- @G- %0 - Q-5 T %% Debug | B cic+ |

‘:'EIlHelpSZ I —
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45 Debug [Zp 3 1| Bc|Sr| Ar
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~ Settings =
G Project settings BEELED R
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%% Debug settings
< >
o

[ conterts %7 search =2 Related Topics [l Bockmarks (5] Index —

AboujProblems

This viguw shows problems that are generated during buiding

See al:
) vigws

[ prhblems View

B quikFix
More results:

b &b

% Search for Frablems view

1. Help view

2. Click to display a list of all the help topics
provided with the IDE

3. Click to activate the Help documentation
search functionality

4.  Click to view the bookmarked help topics

5. Click to view an index of the help
documentation

Tips and Tricks

To open the Help view, select Help >
Dynamic Help or Help > Search.

You can press F1 to activate
context-sensitive help.

Help window—You can also access the
help system in the Workbench window
using the Help window, which opens as a
separate window. To open the Help
window, select Help > Help Contents.
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Cheat Sheets
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1. To launch a cheat sheet in the Workbench
window, select Help > Cheat Sheets.

2. From the Cheat Sheet Selection dialog box,
select the cheat sheet you want to open.

3. Follow the steps given in the cheat sheet to
perform a particular task, such as Creating
and Debugging a StarCore Project.

11
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Other Tips and Tricks

Search Dialog Box

* You can open the Search dialog box by
clicking -+ on the Workbench toolbar or
using the Search menu.

* The File Search tab allows you to search
for files or text in the Workbench.

* The C/C++ Search tab allows you to
search C/C++ elements, such as class,
struct, function, variable, union, field,
enumeration and namespace.

¢ The search functions support the following
wildcards: Use * to represent any series of
characters Use ? to represent any single
character Use \ to represent literals (such
as \*,\?).

Properties Dialog Box

* You can open the Properties dialog box by
right-clicking a project in a view, such as
CodeWarrior Projects or Project Explorer,
and selecting Properties from the context
menu.

¢ The left pane of this dialog box has a Prop-
erties list. This list shows the build proper-
ties that apply to the current project.

* You can use the right pane to modify the
build properties of the project, as required.
For example, to set properties for linker,
assembler, and complier, select C/C++
Build > Settings in the left pane. You can
make the required changes in the Tool set-
tings page in the right pane.

Learn More:

Freescale, the Freescale logo, CodeWarrior, PowerQUICC,

Miscellaneous

* To rename an object in a project, such as
class and type name, variable, and method,
right-click on the object in the editor area and
select Refactor > Rename or press
Alt+Shift+R. The refactoring engine renames
all instances of the object in all referenced
files. You can undo refactoring by right-
clicking the object again and selecting
Refactor > Undo.

* To set software and hardware breakpoint,
right-click the marker bar in the editor area
and select Set Special Breakpoint > Software
or Hardware respectively.

* You can link the navigation views, such as
CodeWarrior Projects and Project Explorer,
with the editor to automatically activate the
file in editor every time you select that the file
in the view. To link the view to the editor, click

& in the view toolbar.

* To open a file in a different editor other than
the default editor, select Open With from the
file’s context menu and select the required
editor.

¢ To restore a maximized view, click the &
icon.

For more information about
Freescale products, please visit
www.freescale.com/codewarrior.
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